Sql server2008数据库驱动下载

2013/5/23 7:23:27 | 阅14036 来源:好空间网络 [打印] [关闭]
 

Sql server2008 是微软最新的数据库,完全兼容 sqlserver2000 和 sql server2005数据库 但是sql server2008 的数据库驱动却和上述2个不一样!

 

我大致和大家介绍下sql server2008 数据库的驱动!!

 

去官网下载回来数据库驱动后得到的是个rar文件,rar文件解压后正常情况下会得到一个jar文件和一些说明文件!!

 

但是 sql server2008数据库的驱动 解压后会得到2jar文件 分别 是 sqljdbc.jar 和 sqljdbc4.jar 文件

 

Sqljdbc4.jar 文件是基于jdk1.6 的数据库驱动

 

Sqljdbc.jar 文件是基于jdk1.6以上版本的数据库驱动

 

通俗的说,就是sql server2008数据库分为2个版本,主要看您的jdk用的是什么版本,而选择自己的数据库驱动!!

 

我把这2个驱动的下载地址给出来大家根据自己的需要选择下载

 

下载后放到自己tomcat/lib文件夹下,重启tomcat即可正常使用

 

 


sqlserver2008数据库驱动.rar

 

 

最新评论
  • 天一:
    我下载了放到工程里面不能连接数据库他也不报错,这个是怎么回事?
    管理员回复:把2008的驱动放tomcat/ib下在看看,我们也遇到过这样的情况,放tomcat/lib下就正常了
    评论时间:2013/9/3 8:6:4
  • 高盛电脑:
    这2个驱动,如果是第一个驱动的话,是不是要把文件名的4去掉?修改为Sqljdbc.jar 在上传??
    管理员回复:亲,不用做任何修改上传即可!!他会自动识别的,但是最好是上传到tomcat/lib文件夹里面,不要上传到自己工程的lib下
    评论时间:2013/9/17 16:24:18
  • 高盛电脑:
    提示:此驱动程序不支持 Java Runtime Environment (JRE) 1.6 版。请使用支持 JDBC 4.0 的 sqljdbc4.jar 类库。我把2个jar都上传了,怎么提示这个错误??
    管理员回复:他这个提示是说您的jdk是1.6的请上传 sqljdbc4.jar 即可,只上传他们2个中间的一个jar驱动,不需要把2个都上传的,另外个jar是jdk1.7才用他的,所以另外个不用上传
    评论时间:2013/9/21 10:12:33
  • annder:
    如果我用了jdk1.6 就上传Sqljdbc4.jar这个文件是吗??如果我用jdk17.就上传Sqljdbc.jar这个文件是吗?能不能把这2个文件都一起上传?他会自动识别jdk的版本吗??另外要是我用1.5的怎么办??麻烦解惑下,感谢!
    管理员回复:亲,是您理解的这样,2个jar不能一起上传的,他不能自动识别的,在使用2008数据库驱动的时候需要先查看您的jdk的版本是多,根据jdk的版本选择上传合适的驱动!!另外2008数据库的驱动没有支持jdk1.5的,,所以就意味着用了jdk1.5则不能使用2008数据库!!
    评论时间:2014/1/26 17:6:57
  • 小小非:
    你们下载的驱动是正版的吗?在你们这里下载和我去官网下载有什么不同吗?是不是去官网下载更好?
    管理员回复:您好,我们的2008数据库驱动,只是为了方便我们的虚拟主机用户,此驱动是我们在微软官方网站上下载的,和官网的一模一样是正版的请放心使用!
    评论时间:2014/1/26 17:18:21
  • mifler:
    把下回来的2个包解压后根据我自己的jdk的版本,选择对应的jar,上传到tomcat/lib下就可以了吗??放我自己工程里面的lib里面可以吗?不知道这2个lib文件夹我应该放哪个里面..
    管理员回复:是的,把对应的jar上传到lib文件夹里面即可!放我们tomcat的lib里面和您自己工程里面的lib文件夹里面都可以,取决于您自己的需要,放我们的tomcat/lib里面,是允许所有的工程使用,相反如果放你自己工程里面的lib里面则是只允许您自己的这个工程使用,其他工程不能调用!
    评论时间:2014/2/24 21:19:9
  • tt:
    谢谢。可以用,我的是jdk1.6
    管理员回复:不客气!
    评论时间:2014/12/10 9:46:54
  • 明天的明天:
    2个jar文件都可以一起上传吗?不知道应该上传哪个!
    管理员回复:您好,2个jar文件只可以上传一个,如果2个一起上传会有冲突,至于应该上传哪个jar 文章里面有说明,根据您的jdk版本而决定上传哪个jar,如果您空间里面的jdk是1.6(或者1.6以下)的 那么只上传Sqljdbc4.jar 反之如果是1.7(或者1.7以上)的版本就上传Sqljdbc.jar 文件就可以了
    评论时间:2015/9/1 8:26:48
经营许可证ICP:皖B2-20100052 公司邮箱:zcdnsz@jspkongjian.net
Copyright © 2004-2015, 安徽好空间网络科技有限公司 版权所有 , 本站素材部分来源于网络,如有侵权请告知删除。